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Introduction 
Welcome to Drainage and Utilities (DU), the Texas Department of Transportation (TxDOT) training 
module for the storm sewer system design and analysis software capabilities within Bentley 
OpenRoads Designer (ORD). The purpose of this manual is to provide training with exercises and to 
serve as a technical reference for engineers and designers. 

DU is a comprehensive design and analysis application that builds sewer networks that are integrated 
with and into 3-dimensional roadway design corridors. This course does not include instruction on 
performing unsteady analysis using Bentley’s CivilStorm products. A tutorial for CivilStorm will be 
developed later. 

TxDOT recently switched software from GEOPAK Drainage to DU for the design of storm sewer 
networks. There was a brief transition period where designers were instructed to use Power GEOPAK 
SS4; those who are familiar with the SS4 software should find the transition easy as the hydraulic 
concepts and criteria are the same. Users not familiar with SS4, should be able to design and analyze 
a storm sewer network using the ORD DU software following this Workflow Manual. 

Objective: Introduce and serve as an instructional guide on how to design and analyze a storm sewer 
network using Bentley ORD DU software. The engineer/designer will need a fundamental 
understanding of drainage design and the Rational Method that is used throughout ORD DU. 

This platform includes storm drainage design and analysis as well as utilities engineering with 
capabilities to include conflict detection and non-drainage attribution. ORD DU has two drainage 
calculation options:   Analysis will not change the physical characteristics of the storm 
drainage; Design may change the physical characteristics. 

It is the user’s responsibility to adhere to the TxDOT Drainage Manual, TxDOT Hydraulics & Drainage 
Directives and Standards. 

Drainage components have been set up to follow TxDOT standards and methods. The engineer is 
responsible for verifying drainage items properties. 

DU uses the terrain model referenced into a DGN file to display the storm drainage and other utilities 
in 2D and 3D. Drainage structures and conduits are fully integrated in graphic and database functions. 

Use DU to: 

• Analyze the existing storm drainage for a project site, a single system or multiple. 
• Analyze the existing storm drainage and upgrade for a project site as needed/needed. 
• Analyze and/or design proposed storm drainage system(s) for a project site 
• Analyze internal drainage structures – driveway culverts and ditches. 
• Analyze conflicts between existing utilities and proposed drainage. 

The designer will be working in the 2D model and DU will create the 3D model the same way as in 
ORD. 

Content Outline: 

This Manual is a step-by-step tutorial that will guide the participant through the steps necessary to 
design a simple storm sewer network. 

The topics in this manual include the following: 

• Project Components Establishing Required Design Files 

• Project Description and Design Criteria 

• Drainage Area and Nodes 

• Laying Out a Network 

• Design and Analysis using Scenarios and Alternatives 

• Computation, Review, and Profiles 
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• FlexTables – Creating Custom Reports 

• Plan Preparation (Hydraulic Data Sheets, Drainage Area Sheets, Plan and Profile Sheets, 
Culvert layout sheets, lateral sheets), and annotation 

The next section gives a brief explanation of the tools and menu bars available for the user to become 
familiar with the workspace. 
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Drainage and Utilities tools 
This guide will not document each tool that is available in the ORD DU interface. See the Bentley 
Online Help for commands not detailed in this document. The Tools below are commonly used: 

Navigate to the Drainage and Utilities Ribbon: 

1. Home tab 
• Attributes – with most workflows, it shows all attributes that are active 
• Primary – opens the explorer, properties, attach tools for references and raster files, 

level manager, level displays (common MicroStation tools) 
• Selection – houses the Element Selection tool, Select All, Select None, and Fence 

tools 
• Model Analysis – Civil Analysis gives the user the option to analyze myriad items. 

A useful tool for the drainage design is the Analyze Trace Slope - The Trace Slope tool shows the 
down/up slope direction of the slope at any one point within the active terrain. The Trace Slope tool 
should be used in its separate file and referenced into the drainage file as needed. 
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• Model Import/Export - Various import and export options. 

o Terrain Import – Creates a terrain model from File, ASCII File, Elements, and Point Cloud 
etc., see Bentley Online help for more Terrain options. 

o Import Geometry from various file types. 
o Import Utilities – Import drainage data from various other software, e.g., InRoads and 

Export Utilities to various other software, see Bentley Online help. 
Terrain import, geometry import or import utilities should be done in a separate file and 
referenced into the drainage file as needed. 

o Export Utilities – Export drainage data to various other software, see Bentley Online help. 

2. Layout tab 

The Layout tab allow the user to build hydraulic and utility networks by placing utility structures, 
conduits, culverts, ditches, drainage areas, gutters, etc. The utility structures are used with clash 
detection tool. The utilities can be below the surface, on the surface or above the surface. 
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• Layout - This is the main tool to place utilities, such as drainage structures and pipes. 
This will be explained in more detail under “Drainage System Layout.” 

• Profile Runs – These are profiles along a series of structures. Different profiles can 
be created from the Start Node or the Outfall, and Links can be added to a profile 
run. 

• Toggles – Will open/activate Civil Accudraw and the Civil Message Center. 

3. Analysis tab 

The Analysis tab sets calculation parameters, standards, constraints, and scenarios for drainage items 
and will be explained in more detail under Drainage Computation. The Analysis tab holds the tools to 
analyze and design hydraulic systems (storm sewer, ditches, culverts) 

• Calculation - This is the center for drainage calculations. 
• Analysis Tools - Holds the Compute Center (one toolbox for access to calculations). 

Default Design Constraints are set to TxDOT standards and should be reviewed for 
project specific constraints (e.g., max. spread, conduit slope). Show Gutter Flow will 
show the path of any overflows from catch basins. 

• Analysis Views - Houses the flex tables – TxDOT-specific flex tables for hydraulic 
analysis have been set up. Queries can be used to report on a specific item. 

4. Components tab 

The Components tab is used to show project-specific storm data, drainage properties, and settings. It 
will be explained in more detail under Section 4 - Drainage and Computation. 

• Common - Create – import Storm Data, select Global Storm Events. 
• Catalog - Access to engineering libraries, inlet – gutter – conduit catalogs, culvert 

inlet coefficients, and rainfall curves from csv files. Prototypes for drainage items are 
set to TxDOT Standards and can be updated to project-specific data if needed. 

• Trenches – Access to template tools, edit template drop, and apply linear template 
for trenches used in the design. 
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5. Utilities View tab 

The Utilities View tools open views of various drainage properties. 

• Drawing Views - Element symbology allows control of how elements and associated 
label are displayed; open profile model generates a view presenting a desired feature 
in profile; open cross-section view creates a dynamic cross-section of a selection 
item. These are the ORD Modeling tools. 

• Results Views - Houses the Flex Tables – TxDOT-specific Flex Tables for hydraulic 
analysis have been set up, and the user can view input data and results for all 
elements of a specific type in a tabular format. 

• Selection and Query - Create, edit, and navigate selection sets; display all queries in 
the current hydraulic model; open the network navigator. 

• Element Views - Properties displays a dialog box containing selected elements’ 
associated properties. Utility Properties displays the subsurface utilities and hydraulic 
analysis of a selected element. Prototypes displays and allows edit to default values 
for elements in a network. Prototypes have been set up to TxDOT Standards. The 
engineer needs to verify the items in the project. 

• Customize - Customize Properties allows customization and changes to default user 
interface. Customize Tooltip allows customization of tooltips that appear when 
hovering over an element. 
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6. Tools Tab 

The Tools tab is divided into general tools and project tools. including “Utilities Conflict” used for 
conflict detection. 

• Tools - Utilities conflicts allow detection of physical clashes and clearances between 
elements. User data extensions allow adding data fields to the hydraulic model 
toolbox. Model builder allows existing GIS assets to construct a new model or update 
an existing model. Update descriptions of conduits in the model. Branch labeling sets 
the labels of conduits. Set feature definition allows setting/locking a feature 
definition. 

• Project Tools - Houses project defaults, i-model configuration to export drainage 
calculations, project properties, synchronizes drawing, and annotation tool to label 
the drainage items. 

• License Activation - StormCAD Unlimited. for systems that have greater than 100 
nodes. CivilStorm is used for unsteady flow analysis. 

7. Report Tab 

The Report tab gives the user fast access to various reports for Tables, Civil and Drainage and Utilities. 

• Report - Custom Report allows the user to assemble a wide variety of model input, 
results, graphs, etc., in a customized report. 
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• Tables - Access to all Flex Tables and Network Elements Table for the utility project. 

• Civil - Access to civil reports such as horizontal geometry report and corridor reports. 
• Drainage and Utilities - Access to various reports and summaries for the drainage 

design. 



12 

8. Drawing Production Tab 

The Drawing Production tab is divided into tables, notes, text, annotation, and named boundaries. 
Explanations are found in detail under the Plans production sections of this workflow manual. 

• Drawing Production tools enable the user to place notes and labels; place and edit 
text; annotate an individual element or an entire model; and enable sheet production 
through the Named Boundary tool. 
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Project Setup 
TxDOT recommends that all design projects are completed and saved in Projectwise. Let’s get started 
with a project.   First step is to set up the drainage designs files in the right project folders. This guide 
assumes the TxDOT Design PM has set up a project folder for the project. All TxDOT projects will have 
a similar folder structure as the one shown below. 

1. Folder structure and reference files location. 
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2. Create a new Drainage Design 
In this case we will be creating a design dgn file in the “Drainage” folder. 

(a) click on the folder you wish to create the file in. For our example it is the models 
Folder. 

(b) Right click on the area to the right of te folder structure 

Your project name here 

THIS AREA 
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(c) Select new and Advanced Wizard: 

• Click next. 
• Select your target folder > Drainage/Model. 
• Click next. 
• Select” Use ProjectWise document as a template” and click on Select. 

Browse to the location of your seed files: 
pw:\\your district folder 01\Documents\_Standards\Configuration\Organization-Civil\TXDOT\Seed\ 
Select the right seed for your file type; in this case, TxDOT_DesignDeed2d.dgn. 

• Click Next. 
• Select your new document name and description. 

• Click Next on the next few screens. 
• Right click on the dgn and select open with 
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• Open your newly created file with ORD. 

Follow the same procedure to create more files from PW. If you have a file already open in ORD, you 
can follow the steps below: 

(a) Select your working folder: 
1) In ORD, navigate to File > New > Select No Wizard > OK. 
2) Select Change… > navigate to the Project Folder > 4 - Design > Drainage > Select 

OK. 

(b) Under Document fill in the name and description fields: 
3) Name: drainage file name, for this example: SH46_Prop_Drainage. 
4) Check the lock box to the right so the name and file name are the same. 
5) Description: drainage proposed – SH46. 

(c) Select the appropriate seed. 
6) Under Source Document:  select (Select Seed > Select TxDOT_DesignSeed2d.dgn 

> Select Open > Select Yes on the Ready Only Dialog). 
The information in your window should look as below: 

(d) Select OK to create the new file in ORD. Check In the Starter file. 

3. Set up your geographic coordinate system 
Once a design file (dgn) has been set up (see steps above), verify your project location and survey 
controls. You must select the proper state plane coordinates prior to attaching design files. 

Navigate to the Drainage and Utilities workflow >utilities ribbon. 

Under Geographic group, select Coordinate System. 
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From the Geographic Coordinate System window, select>From Library. 

From Select Geographic Coordinate System, select TxDOT Coordinate Systems. 

Select the right state plane coordinates. (You will find this information in your survey file.)

 Survey files usually are provided in grid coordinates. To adjust to surface, you will need to apply a 
conversion factor. You can do this in a number of ways: 

First Method 

1) When selecting your coordinate system instead of using from library, highlighted 
below, you can select from file, circled in red: 

2) The survey terrain file that is provided by the surveyor, should have the coordinate 
system with adjustment. 

3) The file will usually be found on the Projectwise folder assigned to the project 
pw:\\server\01\Documents\your district\Design Projects\your project number\1 
- Survey\Terrain Survey\survey file for your project.dgn 

4) This will assign the correct coordinate system to your file. 

Second Method: 

If a terrain file is not available with the coordinates adjusted, and you know your conversion factors, 
you can adjust one of the existing ones to use as your coordinate system: 
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1) From the geographic coordinate system window, select>From Library. 

Right click in the coordinate system, select copy, and paste it in the user custom library folder 
Open the User custom library folder, right click on the coordinate system created, and select Edit 

Coordinate System Properties: 

A new window will pop up: 
Change the projection to Lambert Conformal Conic with Affine Processor 

Update the Affine A1 and B2 Parameters to the conversion factor for your county. In this example, we 
are using the following: 

Click OK when done. Select your user custom file and click OK. Your newly created adjusted 
coordinate system is now applied to your file. 

Third Method: 
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 you can use an attachment reference to assign the coordinate system to your file. This method 
implies that you have already attached a reference file that the coordinate system you will use for you 
project attach. If you do not know how to attach a reference file to a DGN we will briefly explain it in the 
following step. “3. Attach reference files.”  Once your reference file is attached do the following: 

2) Select From Reference from your Geographic Coordinate System window as 
shown below. 

Select the reference that has the coordinate system you want to use. The coordinate system from that 
file will be applied to the active file. 

4. Attach reference files 
You will need to attach all survey, roadway geometry (alignment and planimetric files), existing and 
proposed terrains, proposed roadway corridors, and bridges. All files should be attached with No 
Nesting. 

To attach the files: 

(a) Navigate to Drainage and Utilities > Home ribbon > Primary Group > Attach Tools > 
Attach reference. 

(b) On the References dialog box select Attach Reference.

Under your project folder you will find the following structure: 

Here is a list of reference fles you will need and the folder where you will typically find them: 

Folder 1- survey> Terrain survey> 
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• From this folder you will attach your planimetrics and Existing terrain files. Make sure 
your annotation scale is turned off for this files. You will see the option at the bottom 
of your reference window: 

All other references can keep the annotation scale on. 

Folder 4 - Design\3D Corridor Modeling\Terrain and Surfaces\ 

• Attach all proposed terrain files associated with your project. 

Folder 4 - Design\3D Corridor Modeling\Geometry\ 

• Geometry files will contain your roadway alignment and Profile information. Attach all 
geometry files from this folder. 

Folder 4 - Design\3D Corridor Modeling\Corridors\ 

• This folder contains the roadway 3D corridor files. Attach all corridors files from this 
folder 

Folder 4 - Design\Bridge\ 

• If your project has any bridges this is where you will find the bridge files to attach. 

Fit view 
Set the Terrain Active. On the prior step we attached both existing and proposed terrains. A proposed 
terrain must be created/merged from your proposed corridor and existing terrain. This is typically 
completed by the roadway designer. Select a terrain (existing or proposed) to set active. For proposed 
drainage system design, you will typically need a proposed terrain. Also, as we will see later, we will 
need a proposed terrain for automated DA delineation. 
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By setting the Terrain Active, ORD will create a Default 3D Model. See in the reference dialog, DO NOT 
DELETE the referenced 3D model, this will corrupt your file. As shown below the 2D model is shown on 
the left and the 3D model on the right. There are several preset view options you can access by 
clicking in the active view. Right click in the active view, a context menu will open click on the upper 
option “View Control” Several view options are available. The option shown below is “2 views Plan and 
3D” 

Before we move on to our next 
section here are some important 
recommendations: 

• Do Your Design 
Following/Using the 
Drainage and Utility 
Tools. 

• Save your work often 
and/or make up a back-
up file. Use File > Save As 
within ORD. 

• Free or update server copy 
may cause your drainage 
file to lose connection to 
the database and corrupt 
your file. ALWAYS CHECK-
IN THE FILE(S) TO PROJECTWISE. DO NOT USE FREE OR UPDATE SERVER COPY. 
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Drainage system layout 
In this section we will get started by building an example storm sewer network. 

(a) In the Drainage and Utilities Workflow, select the Layout Tab. 

(b) from the Layout group, select the Place Node tool. 

(c) The following question dialog will pop up. 

(d) Click Yes. This will create your utility model. The utility model is part of the active 
DGN file. It is recommended that you create this in its own file, for example, the 
Drainage design file. Do not use your corridor or geometry files to create your utility 
models. Once  this is created,  IT CANNOT BE UNDONE. 

There are a number of drainage settings and software settings that automatically are added to the 
design file when the Utility Model is created. Some examples of information added would be: 

• Rainfall Runoff Data (Storm Events). the Texas ebd curves are embedded in the 
workspace for selection). 

• Hydraulic information used in calculations (Runoff Methods, Friction Loss Methods, 
Pipe Flow Calculation Methods, etc.) 

• Design constraints (Slope, Velocity, Cover). 
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• Pipe, Inlet, Culvert, etc. catalogs available for placement and calculations. 

Note: OpenRoads is 3D, but the default location for geometry and structures is the 2D Model. Do not 
place structures in the 3D Model. Place all drainage structures in the 2D Model. OpenRoads will 
manage the 3D portion automatically. 

1. Place an Outfall 

To start the design of a drainage system an outfall location must be decided. The outfall must meet 
certain design criteria to be practical. Your network cannot cross drainage basin boundaries, so your 
outfall must be in an area that is inside the overall basin and must ensure there is enough drop to 
meet the TxDOTs minimum 3fps design constraint. 

In this section, we will place an outfall for our system. 

(a) Turn on the Existing Terrain Contours if not already on. Select the Reference File Tool. 

(b) Highlight the Existing Terrain DGN and toggle on the Display. 

(c) Using the Element Selection tool, select the Existing Ground terrain boundary, then Hover 
to access the Element Properties. 

Change the Override Symbology from No to Yes and set the Override Template to 
Terrain\Existing_Contours. 
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The steps above sow you how to access the quick properties box. Alternatively, if you have the Main 
properties window open, you can access the main properties just by selecting an element. To open the 
properties windows and Dock it to the left, do the following: 

• From the home tab primary tools select properties: 

• Select the element. In this case the terrain boundary. The properties window will open. 
• To dock it drag it to the left of the screen. 

Now you will see element properties on the left just by selecting an item. 

(d) Outfalls are usually located at or near low points. We can use the terrain element properties to 
determine and mark the location of this points. 

(e) From the element properties window navigate to the calculated features Display   and togle low 
points and high points on as shown below: 

(f) The file now shows the location of your high and low points. 
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This, in combination with topo features that show the location of major crossings or culverts, will allow 
you to select an appropiate outfall with ease. In this case our low point is near an existing culvert 
crossing. We will use it as our outfall 

(g)  Zoom to the outfall location, as shown in the image. 

In this case, we will place the outlet on the North side of the roadway at the construction limit tie 
slope shown by the red line. The TxDOT workspace uses a generic outfall represented by an “X” 
that will be used as your outfall for calculation purposes. Your outfall conduit should tie into this 
element. 

a) Select the Place Node tool. 

1) Set the Feature Definition to Outfall_Connect. You can find it 
under the Node > StormWaterNodes > Outfalls category. 

2) Set the Name Prefix to OUT – (your system or network name 
here) 

3) Select Reference Element for Node Elevation by Selecting a 
contour line being displayed from the terrain surface, Existing 
Ground. 

4) Toggle On the Vertical Offset option and set it to 0 (The 
Elevation is being read at the invert of the outfall in the cell). 

5) Define Outfall location with a data point. Place along the red 
element that represents the Tie Slope. 

6) Set the Rotation Mode to Absolute. 

OUTFALL 
LOCATION 
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7) Data Point to place the outlet. 

b) Review the Properties and the Utility Properties of the Outfall. 

c) Close the two Properties Dialogs. 
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The “Outfall_Connect” node we placed in the step above contains all the hdyraulic properties of a 
storm sewer network outfall.  Therefore for graphical and visual purposes, a headwall will be 
added. This time we will select feature definition SETP-CD_33in_6H1V_0d from the drop-down 

menu.Follow steps 5 and 6 above. 

d) Click in View 2 to make it active. Select Primary > References and turn on the display for your 
roadway corridor file. Zoom in to the outfall. Your view may vary depending on your Display 
Style setting. 

THE DOT 
REPRESENTS 
THE ACTUAL 
OUTFALL 
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2. Place Drainage Node Without Automatic Catchment 
We will now place the rest of our structures 

(a) Zoom into the location in the model where you want to place your structure. 

(b) click the Place Node tool again. This is under Layout> Place Node tool. 

(c) In the next several steps we will Follow the context menu prompts to place a 
structure. 

(d) From the Place Node window, set the Feature Definition to your structure type: 

(e) Set the name Prefix – a predetermined name based on the structure beign placed 
will be generated. You can change the name if you like. 
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(f) You will be prompted to select Reference Element for Node Elevation. 

• You can select a contour line being displayed from the Proposed terrain surface, or the 
proposed corridor. 

• You can select the Reference Element in the 2D view or the 3D view. 
o In the 2D view, View 1, the plan view cell for the inlet, is attached to your cursor. 

(g)  Set the Snap Mode to Near Snap Point. 

(h) Locate the Feature Curb_Face_FL_R. This represents the flow line in the corridor. 
Make sure you snap to it so you can read the logintudinal slope. 

(i) Set the Vertical Offset Data point in View 1 to accept the Vertical Offset of 0.00. 

(j) Set the Rotation Mode to Relative to Alignment. 
Data point (left click of your mouse) in View 1 to accept that mode. 
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(k) Set the Locate Reference Element for Rotation. Click on the Centerline of the 
Roadway. (project alignment or PGL). 

(l) For the Rotation setting, you will key in N 90 E and click the Tab key or Enter key to 
lock the rotation. The “E” or “W” direction will depend on which side of the roadway 

your inlet is on 

(m) Make Sure the Catchment > Catchment Delineation is unchecked and then Data 
Point(left click) in View 1. 

(n) Select the Element Selection Tool. Select the newly placed inlet 
and then hover over it, and select the Properties. 
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3. Place Drainage Node With Automatic Catchment 
DU has the capability to automatically calculate and create drainage areas for inlet 
structures.  DU must have a Proposed Terrain file to complete this task.   See DES750 for 
instruction on how to create a proposed terrain.  The roadway designer on the project can also 
create the proposed terrain.  

(a) Follow the same procedure above, except this time, turn on catchment delineation. 
We will select a different node for this example. Drainage structures in the TxDOT 
workspace are cataloged as follows: 
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(b) Select the inlet type to use. Select Catchment Delineation and select your 
Catchment Feature Definition as shown below. 

(c) Place your node as in the exercise above. Make sure your proposed terrain is 
selected as your reference elevation for catchment delineation. 

The area will be automatically delineated and assigned to the node. 

You can also assign a predefined area to a structure or trace the drainage area and assign it to 
the structure. We will show how to do this next. 

4.  Assigning a predefined area to a structure – picking your catchment. 
If you chose to trace your own drainage areas, they can be assigned to the inlets with the following 
workflow: 

You can set your drainage area file in advance and reference to your draiwing, but in order to 
assign areas to your structures, areas must be copied to the active Dgn file. 
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(a) select the Place catchment tool form the Layout Tab 

(b) Select your layout method. You have 3 options available as shown below: 

(c) If you have preset shapes, select pick shape. 

(d) If you want to trace your area select pick points. 

(e) Select your feature definition from the list shown above 

(f)  For this example we selected pick shape for the method and Pavement as our 
Feature definition. 
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(g) Click on the area you wish to assign to your inlet 

(h) Data point to accept the selection 

(i) Select the outflow (your structure) 

(j) Select the active terrain. Your corridor or your proposed tin can be selected. 
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(k) your area is now assigned to your structure 

if you do not have predefined drainage area you can alternativly use the Pick points method 
and trace your area. Once your area is traced follow the promts above to assign it to the 
catch basin. 

5.  Setting the Minimum Time of Concentration 
(a) From the analysis tab, Click Analysis > Calculations > Options. 

(b) the following window will popup: 

(c) Double click the Base Design and check the Properties. 
This is where the default value is set for the Minimum Time of Concentration for your 
catchments. This value is used if it has not been set on the individual catchment areas. The 
default value should be 10 minutes. If it is not set, go ahead, and change it here. 

(d) You can check the precision by right clicking on the property, then clicking Units and 

Formatting. 

(e) Close the Properties dialog. 

(f) Close the Calculation Options. 
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6.  Setting the Time of Concentration for the Catchment Areas 
(a) On the Analysis > Calculations ribbon, click Alternatives. 

In the Alternatives dialog, find the Hydrology > Base Hydrology Alternative. 

(b) Double Click on Base Hydrology to view the Hydrology. 

(c) Select the Catchment tab. 

(d) Time of Concentration values can be set here for individual or all catchments. 

(e) Right click on the Time of Concentration (min) column heading and select 
Global Edit. 
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(f) Set the value to 10 and click OK. 

The values are now updated. Remember that individual modifications can be made if required. 

(g)  Close the dialog. 

7.  Placing Gutters 

Placing gutters is necessary to assign by-pass flow in case your structure cannot capture all flow from 
the assigned drainage area. 

1) Methods of Placing a Gutter 

The software has two methods that can be used to place a gutter: 
1. Using Trace Slope - Only asks you to select the start catch basin. 
2. Between Nodes - Asks you to select the two catch basins that are to be linked by the 

gutter. 
The Using Trace Slope method has two prerequisites: 

• The catch basins were both placed using the same terrain model or mesh as the 
Elevation Reference. 

• The catch basins are placed and rotated correctly within the gutter. 

When you select the Start node, the software uses this as the starting location for a downstream 
flow trace, along with the terrain model or mesh element, to find the next catch basin 
downstream. If the Start node was not placed using a terrain model or mesh as the Elevation 
Reference, then you will not be able to select it. 

The rotation of the catch basin is important if the prototype used by the gutter feature definition is 
set up so that cross-sections are created along the gutter. In this situation, the rotation of the 
catch basin should be perpendicular to the gutter flow line, so that a cross-section taken through 
the catch basin, along the bearing of the rotation, will include the shape of the gutter. 

2) the Gutter shape 
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TxDOT has one gutter shape that will be available in DU, which is a conventional Gutter shape. 

The prototype for the gutter feature definition has been predefined in the DU Feature definitions 
and element templates DGNLIB file. 

We will now show the workflow to place the gutters. 

3) Placing a Gutter – Trace Slope Method 

(a) Select Layout > Layout > Place Gutter. 

(b) When the tool is started, there is a check made to determine if Analytic View is 
turned on. 

(c) Select Yes to toggle on the Analytic View because hydraulic gutter definitions are 
visible only by way of the Analytic View. 

Note No labels are shown in the default view. This is a scale issue as our design files are set to 
1” =100’. 

(d) On the Drawing Production ribbon, select Drawing Scales > Annotation Scale. 
Select the drop down and pick Full Scale 1:1. The text is now visible. 
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The display shows useful information, but it may be overpopulated for placing gutters. 

(e) In the top left corner of View 1, Select View Attributes. 

(f) Ensure that the Select Product property is set to Drainage. 

(g) Change the Symbology Definition from <default> to Pipe Size Color Code. 
You can change back to <default> or other definitions later. 

Note that Analytic Symbology can be turned on and off in View Attributes (remember you 
will not see the gutters if it is turned off). 

(h) Go to Home > Primary > Level Display, click on the Drainage Design DGN and turn 
off the levels of DU_Storm_Areas and DU_Storm_Conduits.  

After that, click on the Roadway Corridor Reference and turn off TL_Curb, TL_Pavement 
Edge, as these levels will overlap the newly placed Gutters. 

(i) Set the Method to Using Trace Slope. The path of the gutter will be calculated 
by tracing a slope downhill along the Elevation Reference surface. 

(j) Set the Feature Definition to Conduit > StormWater > Gutters > 
Gutter_2ft_Convent. 
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(k) The Name Prefix  is set automatically to GU-. Following the prompts, at Select Start 
Node data point the upstream catchbasin. 

. 
The path of the downstream flow trace to the downstream catch basin is shown in orange. 

Data point to Accept Trace Slope. 
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4) Between Nodes Method 

(a) You can also use the Between Nodes Method to place your gutters. 

(b) Change the Method to Between Nodes. Both catch basins need to be selected 
in this method. 
Note: The TxDOT workspace only has 1 feature definition option for gutters. 

• This feature definition will use the same gutter cross-section as the Stop (downstream) 
Node. 

Following the prompts, at Select Start Node data point your PC catch basin. 

Note that, when you are using the Between Nodes method, you should pick a suitable 
location on the proper side of the catch basin, relative to the direction of the gutter. 
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8.  Place Conduits and inserting nodes 
1) `Place Conduits 

In this section, we will cover creating drainage pipes to connect our previously placed nodes. 
We will begin at the downstream end of our network system. When placing the pipes, 
we will always ensure to place the pipe beginning at the upstream node and ending at the 
downstream node. 

(a) First, we will turn off the display of several reference files to simplify our view. 
Select the Reference File tool. 

(b) Toggle off the Display of every Reference file in View 1 except the GEOMETRY OR 
ALIGNMENT FILE. 

(c) Close the Reference File dialog. 

Note: In a prior step we turn off the pipe display in the 2D view to be able to see our 
gutters. Go ahead and turn the DU Storm Conduits level back on. 

(d) Select Drainage and Utilities workflow, then Layout > Layout > Place Conduit. 
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(e) The Place Link Between Nodes dialog will appear. 

(f) We will set the Feature Definition. 
1) Set the Feature Definition to RC_Pipe_Cl_III found in the Conduit > StormWater 

>. 

The StormWater conduit feature definition holds all pipe, culvert, and ditch types available 
for design, including Existing, as illustrated below 

(g) Set the Name Prefix. A standard name has been set, but it can be changed to your 
preferences. 

(h) Select 18” for the Description. 

(i) Toggle Off Civil AccuDraw if it is still on. 

(a) The first prompt is to select the Start Node. 

(b) Next you are prompted to select the next node to make a connection. 
Note: Always place conduits from the upstream node to the downstream node. 
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(c) The pipe is placed in the plan view and modeled in the 3D View. 

We will continue in the Place Conduit tool and connect the rest of our system. 

(a) Select the Place Conduit tool from the Drainage and Utilities Workflow > Layout > 
Layout. 

(b) The sketch below shows how the conduit and node system will look in the plan view. 

Note: Remember to place each pipe from the very first upstream inlet in your network and 
work your way downstream towards the outfall. 
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(c) Using the Element Selection tool, select one of the pipes you just placed and Hover 
over it to access the Properties Dialog and the Utility Properties dialog from the 
Context Menu. 

(d) Close the Properties and Utility Properties dialogs. 
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2) Insert nodes 

In this section, we will insert a manhole node into our Pipe. 

(a) In View 1, Zoom so that you can see one of the conduits. We will place a manhole in 
the middle of this pipe. 

(b) Click in View 2 to make it active. 

(c) Pan or zoom so that you can see the conduit in that view as well. 

(d) Make View 1 active again by selecting the view title bar. 

(e) Select the Insert Node tool from the Drainage and Utilities Workflow > 
Layout Tab > Layout. 

(f) We will preset the tool settings for the Insert Node tool. 
1) Toggle Off Vertical Offset. 
2) Toggle On Split Conduit. 
3) Set the Feature Definition to Node > StormWaterNode > Manholes > PRM_48. 

The Name Prefix is preset to PRM-. 

(g) The tool prompts you to Select Reference Element for Node Elevation. 

(h) In View 2, the 3D view, select the proposed terrain. 
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(i) Select Conduit Invert Reference element, select the Conduit in the 2D view. 

(j) Toggle Split Conduit to Yes by toggling the option on in the tool settings. So all we need to 
do is Data Point to accept Yes. 

Now you will need to select the location where to insert the manhole. Pick a location and Data Point. Location 
is not critical. 
Set the Rotation Mode to Relative to Alignment and Data Point. 

(a) Locate Reference Element for Rotation. 

(b) Click on the Centerline of the Roadway, 

(c) For the Rotation setting, you will key in N 90 E and click the Tab key or Enter key to lock 
the rotation. Then data point in View 1. 
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(d) Zoom to the Manhole in View 1. 

You can see from the view above that there will be some clean-up. You can move the two 
pipe ends to connect where you would like around the manhole, and you can rename the 
pipes if needed. Check that your connection points at the up and downstream inlets are 
attached to the correct side as well. 

Note: To move the pipe, you would select it, then click on the Reconnect Link graphic 
handle and move it to the desired connection point. 

Before continuing, left click in View 1. Using the References tool, check that the 
Corridor reference file is turned On. 
There are special workflows for placing POD inlets and creating lateral connections to an 
outfall. Also, we recognize the need to tie proposed drainage systems to existing pipes or 
structures. These particular cases will be addressed in more detail in the SPECIAL 
WORKFLOWS SECTION OF THIS MANUAL. 
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9. Drainage system layout - special workflows 
1) Extend Existing Pipe Using a Transition Node 

(a) Place the existing structures using the Place Node command. This can be any node. Use the 
proposed nodes. User can change the line style in their file. 

(b) Place the existing conduit using the Place Conduit command.  Scroll to StormWater > Existing 
>. Use any of the 3 available conduits and select the size of the existing conduit, place from 

Start Node to Stop Node. 

(c) Run your calculations for the “Existing System.” 

(d) Change extend the conduit with a proposed conduit.  Remember the Node if deleted will also 
delete the conduit. To keep the conduit, we need to switch the feature definition. 
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(e) Change the Feature Definition for the Existing Node. In the Node Properties > Feature 
Definition > use the pull down. Click on Transitions >. Pick Attach_Exist_CMP or 
Attach_Exist_CONC.  This will change your structure node to a Transition node.  Type in a 
Feature Name for the transition > TR-1 (numbering is not automated) 

(f) Use the Place Node command to place the proposed structure node to the location needed. 
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(g) Use the Place Conduit command to place the proposed conduit from the transition node 
(previous existing node) and the proposed structure node. Start at the highest elevation to the 
lower elevation. 

(h) Finished. Calculate the proposed condition. 
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2) Place POD inlets and lateral connections 

(a) Select layout tab. 

(b) Select Place lateral tool. 

1. On the place lateral window select: 

•  node feature definition – your inlet or structure that will tap into the trunkline 

• Tap node Feature definition – your transiton tap node 

• And feature – size, type, and material of the pipe or culvert that will tap into the 
trunkline 

(c) follow the context menu prompts at the end of your 
cursor: 

1. select your proposed terrain contours 

2. Select the trunk line you will be tapping to. 
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3. You will now see your structure attached at the end of your cursor and you can define your 
parameters 

• In this case the lateral is 90 
degrees oor perpendicular to the trunk line  and 
rotated 43 degrees. You can change this to 0 
degrees so the structure lines up with the trunkline. 
If your connecting pipe is coming at a skew, you can 
select the required skew angle. 

4. PODs will attach to the trunkline from the top. So move your inlet as close as possible to you 
trunkline without touching it. Data point or right click to accept 

Once your tap node is created, you can add the drainage area manually and assign it to the node or input the 
added flow. You can change the location or rotate the inlet like any other structure. 

All PODs or lateral connections will need to be done this way. 
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10. Create Profile 
In this section we will create a Profile Run. This profile will be used to aid in our design and to develop our plan 
profile sheets. We will discuss this in more detail under the Plan production section of this manual. 

(a) Select one of the contours in View 2 that represent the terrain and hover until you get the context menu. 
Then select Set as Active Terrain Model. 

(b) Select the Hydraulic Run from Node tool located in the workflow Drainage and 
Utilities > Layout > Profile Runs. 

1) Set the Name to your preference. You can change the name later. 
2) Set the Feature Definition to Linear > Miscellaneous > Util_Profile_Run. 

3) Set the Name Prefix to Util_Prof_Run. 
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(c) Select the Open Profile Model Icon and Data Point in View 4 to place the profile. 

Note how the soffits match. 

Up to this point we have showed you how to: 

• create your drainage project, place your outfall, 
• place structures with and without automatic 

catchment delineation, 
• add gutters, 
• add drainage areas and assign them to your 

structures, 
• connect your structures with conduits 
• add structures between conduits. 
• Create profiles. 

All the elements created on your model are classified by type 
and can be viewed in the project explorer under the drainage 
and utility Model tab as shown on the right. The project 
explorer can be found on the home tab under the Primary 
tools as shown below: 

We will now show you how to set your rainfall parameters, 
compute your network and view the results. 
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Compute the System 
In this section we will compute the system. No adjustments will be made. The software will simply 
compute the flows and provide you with a summary of the results for your review. 

There are some settings you will have to go through to set up your storm event and location for your 
rainfall parameters. We will explain that in detail and show the location of the rainfall libs and how to add 
it to your scenarios before running the analysis 

1.  Setting up the storm event 

(a) Leave the Profile View open. 

(b) Before running any computation, we need to set our storm event. 
1) Select the workflow Drainage and Utilities, then select the Analysis Tab. 
2) Select Alternatives from the calculations group. 

The alternatives window will open. Select the rainfall runoff and set the name to your desired location 
and return period. 

You can also create an additional alternative and set your preferences. 



57 

1) Right click on the Rainfall runoff and select the desired option. You can create a separate 
base alternative or a child of the existing. For this example, a child will be created. 

2) Double click on the rainfall runoff (Bexar County 10 year) and select the storm event. 
3) Close the alternatives window. 

You also could Select Storm Data from the components tab and select Global Storm events from the 
drop-down menu. 
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You will see your created alternatives listed. This way you can set up all your preferences for each scenario at 
one location. 
Click on the global storm event column and select the storm event and location from the drop-down menu. 
Close the global storm event window 

2. Run the Analysis Scenario – Compute your System 

(a) Select the workflow Drainage and Utilities, then select the Analysis Tab. 

(b) From the Calculation Group, select the Scenarios Tool. 

(c) Select the Base Analysis option. Right click and select properties 

On the Scenarios dialog, click the green Compute Scenario icon. Do not select 
Compute icon on the ribbon menu. 
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The hydrology and hydraulics calculations are carried out, and after a few moments, the 
Calculation Summary dialog above will open. 

Note: Convergence was achieved is good news! Also, note that the dialog shows the Storm 
Event Properties. 

(d) You can click the Details button to review the calculations. You also will notice that the profile is 
updated with the Hydraulic Grade Line being shown. 

(e) Close the Calculation Summary dialog when finished. 

We will now let the software design the system. But first lets discuss a few differences to take into 
account when laying out and analyzing the system as opposed to letting the sofware design it. 

3. Invert Values during Layout and Design 
During layout, inverts are set via these parameters: 
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• Nodes’ inverts are the Ground Elevation (Terrain) minus the Height of the Node 
(either two cell elevation points or the Default Height field - depends). 

• Pipe inverts are set at the adjacent nodes’ invert elevation. 
• Ditch inverts are set at the adjacent nodes’ invert elevation. 

During a design calculation, object inverts may be adjusted by these parameters: 
• Pipes will try to meet minimum cover, minimum slope, and minimum velocity criteria. 
• These criteria are set by the Default Design Constraints and are assigned to each 

conduit at Layout. 
• Each conduit end will lower or raise the adjacent nodes invert with them (excluding 

Outfalls). 
• Conduit Channels behave like pipes: They try to meet minimum cover, etc. during 

design. 
• Channels from Node do not get adjusted during Design. 
• Outfall Inverts do not change during Design. 
• Cross Section Nodes do not change during Design. 

4. Let the Software Design the System 
In this section, we will adjust a few settings and allow the software to design the system for us. We will 
allow the software to adjust Pipe Sizes and set Pipe Inverts for best system performance. 

Note: When in design mode, the inverts cannot be manually adjusted/changed. To change 
invert elevations designer must switch to analysis mode. 

(a) In the Scenarios dialog, select Base Design, right click on it, and select Compute > Scenario. 

The software will begin to compute the scenario. The software recognizes that in a Design 
Calculation, Pipe Sizes, Invert Elevations, and other physical properties will change from your 
original layout. 

The software stops the process to allow you to save these new sizes and elevations under a 
separate name of your choosing. Doing so makes it quite easy for you to return to your original 
data if you wish. 
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(b) Click the Yes button. 

(c) Type in a name for the Physical properties alternative. 
For example, key in Bexar 10 year Designed By Software. 

(d) Click OK 

(e) The software continues to compute and optimize the design, and eventually the Calculation 
Summary dialog will appear. 

(f) Click the Details button to review the Link Summary. 
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(g) Close the dialogs when finished. 
The Profile View should still be open and has been updated to the current design scenario. 

(h) Open the Explorer window and expand the Drainage and Utilities Model Tab. 

(i) Expand the Profile Runs and Right click on the Profile Run profile and select Open Analysis 
Profile. This profile will display in its own window. 
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(j) Click the Down Arrow next to the Chart setting icon in the upper left corner of the 
Profile window. 
Select Show Profile Annotation Table 
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(k) Pipe information is shownalong the bottom of the Profile view window. 

(l) Close the Profile analysis window when finished. 

In the next section we will discuss how to create a ditch network and how to add and design a cross 
culvert. 
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Placing a Ditch and Culvert Network 

We will now show the workflow to place a ditch and culvert network. Workflows are like the ones used to create 
a pipe and inlet network so we will focus only on the minor difference to set up your ditch system. 

While Ditch systems can be analyzed using ORD DU, we will use this workflow only as a graphical tool to display 
ditch elements in profiles. Separate capacity calculation must be run to design ditches utilizing the same 
method used prior to ORD DU. The TxDOT workspace supplies a limited number of ditch sections but allows the 
designer the ability to create as many ditch sections as needed. This is discussed later under the Place the 
ditch workflow. The method used by the TxDOT workspace assumes no ditches exist in the terrain. 

• Terrain without Ditches (or Invert Below Grade). 
• The ditch bottom or even the ditch itself is NOT reflected in the terrain model. 
• The terrain does not model the ditch. A primary example is a new proposed ditch to 

be placed on existing ground. 

Note: While the focus is on the ditch, the inverts are dictated by the upstream and downstream Nodes 
(Endwalls, Cross Section Nodes, etc.). 
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1.  Place the Headwall and Endwall 
We will be placing a pipe under a driveway near the property line. 

Later we will place ditches upstream and downstream of the driveway. 

All Conduits must attach to Upstream and Downstream Nodes. The nodes must be placed prior to 
placing the culvert. Given the upstream and downstream ditches, the right nodes are SETs. We will 
place them now. 

Note that the software has a Hydraulic category for Headwalls. “Endwalls” and Headwalls are identical 
as far as the software is concerned. 

(a) Select the Layout > Layout > Place Node tool. Feature Definitions are how we choose the specific 
object type. The TxDOT Workspace has a variety of Headwalls and SETs under 
Node >StormWaterNode >Headwalls. 

(b) In the Place Node dialog, 
1) Set the Vertical Offset to 0.0. Ensure the box is checked. 
2) Set the Rotation Mode to Absolute, clear the Rotation check box. 
3) Click the Feature Definition list. 

Feel free to see how the workspace Headwalls are organized. 
4) Select Node > StormWaterNode > Headwalls > PSET-RP_P-D_Round >select the SET. 
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(c) At the Select Reference Element for Node Elevation prompt, select your corridor. 

(d) At the Define Headwall prompt, ensure that the Vertical Offset is zero. 

(e) Find a DW on your Roadway file and data point to locate the SET. 
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(f) Place a datapoint to confirm the Rotation Mode as Relative to Alignment (or press the 
Down Arrow key to change it to Absolute). 

(g) At the Select Rotation or Reset to Place again prompt, drag the cursor to rotate the headwall 
along the path. 
Note: If there is a Lock icon to the left of the Rotation field, click the End key to free the rotation. 
Rotation does not need to be exact. 

(h) Place a datapoint at the intended rotation.This places the Headwall and the command loops to 
the Define Headwall prompt. 

(i) Place another Headwall on the other side of the driveway, similar offset, similar orientation. 

2. Place the Pipe 
Place the pipe between the headwalls. The difference between a “pipe” and a “culvert” is the 
hydraulic method. The difference between a software “pipe” and a software “culvert” is a field called 
“Is Culvert?” which triggers the proper calculations. 
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You can set up Feature Definitions for Culverts by setting the Prototype’s Is Culvert? field to True. By 
convention, however, all the Workspace pipes are Pipes rather than Culverts. Unless you change a 
Pipe to a Culvert, the calculation will be Pipe Calculation. We will show the culvert workflow in more 
detail later. 

(a) Click the Place Conduit tool from the Drainage and Utilities Workflow >Layout > Layout. 

(b) In the Place Link Between Nodes dialog, set the Feature Definition to Conduit > StormWater> 
RC_pipe_Cl_III. 

(c) For Description, select 24”. 

(d) At the Select Start Node prompt, click on the upper headwall. 

(e) At the Select next node to make a connection prompt, click on the lower headwall. The 
command loops. 

(f) Reset to exit the tool. 
Notice that you were not prompted for invert elevations. Pipe elevations are based on the inverts 
of the nodes and the Cover Depth as defined in the Default Design Constraints. 

The Pipe Inverts match the SET Inverts. 

Note: Although SETs are under the Headwall category, SET cells do not have a top locator point, 
so when placing SET structures, your ground elevation is the invert elevation, or the FL of your 
ditch. 

3. Place the Outfall 
All Conduits - pipes, ditches, etc. - need Nodes at both ends. Now we will place a downstream node at 
the Outfall location. 

There is no necessary physical difference between a Headwall/Endwall and an Outfall. There are 
some subtle differences in the hydraulic properties of a Headwall/Endwall vs Outfall. An outfall can 
accept a wider variety of hydraulic Boundary Conditions and must be used at the end of your system. 
They are useful when routing ponds, for example. 

A given physical object may be used as either a Headwall/Endwall Feature or as an Outfall Feature, or 
both. 
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Due to how they link to different Hydraulic Prototypes, you will want to be clear in your workspace 
which type of object it is hydraulically: 

The TxDOT Workspace has one generic Outfall under its own Outfalls heading. Objects under this 
heading use the Outfall Hydraulic Prototype. This manual has a special workflow to place an outfall 
and to connect the outfall structure. It is explained in more detail under the SPECIAL DU WORKFLOWS 
SEGMENT. 

(a) Click Drainage and Utilities > Layout > Layout > Place Node. 

(b) In the Place Node dialog, set the Feature Definition to Node > StormWaterNode > Outfalls > 
Outfall_Connect. 

(c) At the Select Reference Element for Elevation prompt, pick any visible terrain element (a 
nearby contour). 

(d) Define Outfall > Vertical Offset > 0. 

(e) At the Define Outfall prompt, place the Outfall Node at your outfall location. 
The primary variable here will be the elevation, which will affect the pipe slope. We’ll explore and 
adjust this later. 

(f) You then are prompted to Select Rotation Mode. Place a datapoint < D > to confirm 
Absolute. 

(g) At the Select Rotation or Reset to place again prompt, place a datapoint < D > in the ditch 
so that outfall is rotated in line with the pipe. 

4. Place the Ditch 
Now that we have an upstream node and a downstream node, we can place a ditch. 

Note that a fundamental property of a ditch is its Cross Section Geometry. Ditch Cross Sections can be 
Rectangular, V-shaped, Trapezoidal - or any shape via Irregular or User Defined shapes. 

When laying out Ditches, be aware of the shape you pick. Clearly named Feature Definitions are 
important. 

Only a few ditches Feature Definitions are provided in the TxDOT library. It is easy to add more cross 
sections as needed. We will now show you how. 

(a) To review the available items catalog and add new items; 
1) Click Drainage and Utilities >Components > Catalog > 
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2) Select Catalog>Conduit Catalog from the drop down. 

3) Select the TxDOT Grass Ditch label. 

4) A list of available ditch sizes is provided. To add a new ditch to the catalog, select the conduit 
shape, and click on new under the Catalog of Conduits Class Sizes heading. 

5) A new entry is created. 

6) Select the label (for example: 2ft_W_x3ft_D_6H1VL 4H1VR). 
7) Check the available for design box and set all the physical properties of your ditch. 

8) Close the conduit catalog window. 

(b) We will now place the newly created ditch section: 

1) Click Drainage and Utilities > Layout > Layout > Place Conduit. Set the Feature 
Definition to Conduit > StormWater > Ditches >Ditch (Grass). 
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2) Click on the Description list. This defines the Cross Section geometry. 
Feature Definitions that are linked to a Catalog - like this one - will list their available 
sizes. You will notice our new added ditch is now available. 

3) Click 2ft_W_x3ft_D_6H1VL 4H1VR. 
This naming convention indicates the width, the height, and the side slopes. 

4) At the Select Start Node prompt, click the upstream node. 

Hint: You do not have to be zoomed in tight. The software will accept only graphics right for 
ditches: Headwalls or Cross Section Nodes. 

5) At the Select next node to make a connection prompt, click the downstream node. 
The ditch is placed, and the command loops. 

6) Select < Esc > to exit. 
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5. Break the Ditch 
Our ditch nodes are far apart, and the straight line between them diverges from the property 
boundary. You can place a bend in any conduit during layout or afterwards, but they are horizontal 
bends only: 

• During placement, prior to picking the stop node, you can click the <Ctrl> key to 
place vertices. Click <Ctrl> again to pick the stop node. 

• After placing a ditch, you can use Bend Link Segment from the ditch’s context 
menu. 

These have a single slope and single “hydraulic fields” (a single flow - Q, velocity, depth, etc.). 

If you need a grade break or need to add flow, you will need to insert a node. This will break the 
conduit/ditch into two, each with full database properties. 

For our ditch, we will insert an intermediate node. This way, we can follow the ditch from the roadway 
model more closely and have a different slope as we approach the outfall. 

“Structure-less” Ditches 
Ditches are different from pipes: Pipes always are physically quantifiable objects. 

Ditches can be physical objects, such as a concrete-lined trapezoidal ditch. Natural ditches and new 
“dirt ditches” are not physical objects that show up on plans and in quantities. 

Cross Section Nodes allow you to place start/end nodes and intermediate nodes without adding 
“physical objects.” You get the ability to: 

• Store x,y, z coordinates in the model, 
• Accept added flow, and 
• Change the ditch cross section. 
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Our ditch is grass. Adding a bend is simply a matter of turning the bulldozer: no physical object at the 
bend is needed. A Cross Section Node is perfect for our needs. 

The image below shows the workspace’s Ditch Cross Section nodes. Note that the Feature Definition 
names include the Material and Cross Section shape. 

Note: A Ditch’s shape is NOT bound by the Cross Section Node. We will discuss this later. 
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(c) Let’s break our ditch into two by Inserting a Cross Section Node. 
1) Click Drainage and Utilities > Layout > Layout > Insert Node. 
2) Set the Feature Definition to Node > StormWaterNode >. 

XS_Grass_2w_x_1d_4H1V. 

3) At the Select Reference Element for Node Elevation prompt, pick the roadway corridor 
boundary. 

4) At the Select Conduit Invert Reference prompt, click on the ditch. 
5) At the Split Conduit prompt, indicate Yes. 
6) At the Define StormWater Node prompt, ensure that the Vertical Offset reads zero, then 

locate the node with a datapoint <D >. 
7) The break location is located in the ditch. The node can be moved freely after it is placed. 
8) You are then prompted to Select Rotation Mode. Place a datapoint < D > to confirm 

Absolute. 
9) At the Select Rotation or Reset to place again prompt, place a datapoint < D > along the 

ditch. 
10) Ensure the ditch node is at right angles to the ditch. 
11) The Ground Elevation is the terrain. The Invert Elevation is the Ground Elevation, which 

is the same in this case. 
12) Once your ditch is in place, use the Layout profile runs under the layout workflows to 

create your profile. 
13) Use the Place catchment workflow to add catch basins to your ditch. 

Note:  There is a natural tendency to want to assign the drainage area to the node at the 
downstream end of a ditch. It drains in that direction, right? This is good for inlets, but not for 
ditches. 

If you do that, then none of the flow gets into the ditch for calculations. Attach the Catchment to 
the upstream node of the ditch. This way, you get all the flow in the ditch for maximum flow, 
depth, and velocity values. 

In reality, you get incremental interception of flow as you move from the upstream node of each 
ditch to the downstream node. If you need a more exact and “granular” flow design result, you can 
insert additional intermediate nodes and use smaller catchments to cover the areas. All these 
values decrease as you move upstream from the downstream end of the ditch. 

(d) Follow the analysis workflows for scenarios and alternatives to analyze and design your ditch. 
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6. Place and Design a Cross Culvert 
In this section we will show how to place and design a culvert. 

Note: The Elevation Reference – the terrain - is assigned to what is labeled in 
the Properties dialog as the Ground Elevation. 

To be precise, for all Headwall cells, the Ground Elevation is the elevation of 
the top Locator Point of the cell. 

The Vertical Offset set in the dialog/Heads Up 
Display is the difference between the Ground 
Elevation Point and the Elevation Reference (the 
Terrain). 

The Invert Elevation is this Ground Elevation 
minus the height of the Headwall, either: 

• The Default Height of Headwall - 
as defined in the headwall’s 
Prototype, OR 

• The Elevation Difference 
between the top and bottom 
elevation indicators in the 
Headwall 3D Cell definition. This 
is explained in detail in other 
documentation. 

For example, if the Height of the Culvert Headwall used is 3.0’ and the Terrain is at 
100 ft, the Invert Elevation would be 97 ft. 

Make the Pipe a Culvert 

We placed a pipe. If we do nothing, it will be calculated as a pipe, which is fine for most applications. It 
is likely that the flow through it does not require “Culvert Calculations.” For this example, we will place 
two Headwalls and a pipe and set it as a culvert for calculations. 

There are two parts to Culvert Calculations: 
• Set Is Culvert? to True 
• Ensure the proper Culvert Coefficients for the Calculations. 

GROUND ELEVATION 

INVER T ELEVATION 
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(a) Select the pipe, hover, and open Utility Properties from the context menu. 

(b) In the Drainage tab, find the property for Is Culvert and change to True. This opens other 
fields. 

Culvert Calculations need coefficients describing the hydraulic properties of the ends of the 
culvert. An Upstream Headwall Definition and a Downstream Headwall Definition are needed. 

The options for each are 

• Use Conduit - Define the values here in the dialog or 
• Use Node - The attached Headwall has coefficients defined in it. Selecting this option reads 

those coefficients. 

(c) TxDOT Workspace Headwalls have coefficients defined. Set both fields to Use Node. 

(d) You will now set your area, for the inet headwall, and run the analysis or design scenario as 
needed as shown in the Compute the system section. 

We have so far show you how to create and analyze or design your drainage system. In the next few 
sections, we will discuss valuable information that will aid in your design process. 
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Any object can be “locked” via the Design Alternative settings (see next section). 

Controlling Object Design 
One sure way to ensure that no object properties get adjusted unintentionally is to perform an Analysis 
Compute Option. An Analysis computation routes the flow through the system without changing any of 
the physical object properties. 

Sometimes we want to have the software size only some of the objects, rather than all the objects. 
During placement, an object’s database fields are populated from the Feature Definition, the Hydraulic 
Prototype, and the Default Design Constraints (Drainage and Utilities > Analysis > Analysis Tools 
> Default Design Constraints). 

You can view each object’s data record using the Utility Properties dialog. 

Alternatives are logically organized based on purpose. This helps reviewing and editing multiple 
objects targeting specific characteristics. This will be explained in more detail later 

Design Alternatives group objects and properties related to design behavior. To open the files 
Design Alternatives, click Drainage and Utilities > Analysis > Calculation > Alternatives. 
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A Conduit Ditch’s Feature Definition can set a Local Design Constraint to override the global Default 
Design Constraints. You can also set after objects are placed in the Constraints in the Design 
Alternatives dialog. 

Design Conduit allows for automatic sizing of closed conduits only. Open Channels are not sized 
automatically. 

Design Start or Stop Invert allows the software to change the invert elevations. Clearing the check 
box will “lock” the elevation. 

Note that no Channels from Node are shown here; they are “Channel Type” elements. This dialog 
shows “Conduit Channels.” Neither are “designed” by the software - the software does not size them. 

Please refer to the workflow on Pipe Networks for detailed Scenario Management and Computation 
Instructions and Troubleshooting. 

1. Pipe Sizes available for Design 

(a) In the workflow Drainage and Utilities switch to the Components Tab. 

(b) In the Catalog Group click the down arrow under the Catalog icon and select Conduit 
Catalog. 
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(c) The Conduit Catalog will open, and we will select TxDOT RCP Class III - circle under the 
Label column. 

(d) In the Available for Design column, notice the options for 12” and 15” sizes are toggled off. 
There is a second Available for Design check box, further down the dialog, in a frame called 
Class Availability. 
Clearing this check box would mean that the complete class would not be considered when the 
software calculates the size of conduit that is needed. This might be right if you have a class that 
is purely for some existing conduits, which are not available to use anymore. 

NOTE:  While all pipe sizes are available for use, the minimum pipe size for TxDOT design is 24”. 
For details, please refer to the TxDOT Hydraulic design manual. 18” may be used in some cases 
with the engineer’s approval. 

(e) Close the Conduit Catalog. 

2. Conduit Properties 
On the Tools ribbon, select General Tools > Update Descriptions. This will update the 
conduit descriptions, which by default come from the prototype so they reflect the conduit 

diameters that you chose when placing the conduits. These descriptions are visible in the Utility 
Properties of each conduit. 

(a) Click OK on the message which confirms that the update is complete. 

(b) Select a conduit  and open Utility Properties. 

(c) Note the Physical Set Invert to Start? and Set Invert to Stop? Are both set to True? 
True means that the invert elevations of the conduit will be set to the invert elevation of the 
connected nodes. 

The Conduit Description is also shown in the Physical category. 
The default values for these properties were set in the Prototype that the conduit feature definition 
uses. 



81 



82 

Understanding Scenarios 
• There are hundreds of properties involved in hydraulic design and calculations. 
• Regulatory agencies often require analysis on multiple variations of constraints (such as multiple storm 

events). 
• The engineering design process itself often requires evaluation of alternative solutions. 

Having a logical and manageable system to manage and compare the variations in the hundreds of properties 
is essential to ensure optimum design. This is what the effective use of Scenarios offers you. 

Drainage and Utilities groups comparable properties into function-based groups called Alternatives. 
Calculations are then performed on a bundle of Alternatives, which are grouped together in Scenarios. A 
Scenario also controls how the calculations are performed, in the Calculation Options. 

• Property – A property is any stored characteristic of a model element. Examples include: 
o A single numeric quantity such as a pipe’s Diameter, Length, or Roughness. 
o A Yes/No toggle such as Design Conduit? 
o A value from a list such as Design or Analysis for Calculation Type 

• Alternative – An Alternative is a logically organized set of properties. Examples include: 
o Physical Alternative – groups physical data for the network's elements, such as elevations, sizes, and 

roughness coefficients. 
o Design Alternative – groups engineering criteria that will be applied during calculations such as 

velocity limits and other settings that may or may not be applied during calculations, such as adjusting 
pipe diameters and inverts. 

o Rainfall Runoff Alternative – allows different storm events to be used in calculations. 

• Calculation Options – a Calculation Option contains properties that control how to ‘solve’ the hydraulics 
and hydrology of the drainage system. Examples include: 
o Calculation Type – whether the system is to be analyzed (does not change elevations or sizes) or 

designed (hydraulic optimization of elevations or sizes) 
o Active Numerical Solver – the methods used for the calculations, such as ‘Rational Method,’ and the 

settings that the method needs. 

• Scenario – a Scenario has a set of Alternatives, and the settings that control how the hydraulics and 
hydrology are calculated. This “bundling” of Alternatives lets you easily generate system conditions that 
mix and match groups of data that have been previously defined. Note that Scenarios do not actually hold 
any attribute data – the referenced alternatives hold the data. 

There is always a current scenario. It specifies the current alternatives. The current alternatives are where 
your data is stored. 

You can use multiple Scenarios to calculate multiple "What If?" situations in a single project file. You can try 
several designs and compare the results or analyze an existing system using several different input 
alternatives and compare the results. 

Scenarios and Alternatives can “inherit” properties from other Scenarios and Alternatives. These Parent-Child 
relationships are a critical tool in easily managing variations from otherwise global properties. 

When creating a new project, Scenarios and Alternatives are copied from the Hydraulic Seed File. This is a 
DGN Library, which is specified in the WorkSpace or WorkSet configuration. 
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1. Scenario Manager 
The Scenario Manager is the primary interface for creating, editing, and managing an unlimited 
number of Scenarios. 

There must be at least one Scenario. Additional Alternatives and Scenarios are easily created to 
handle any design requirements. 

Examples include: 
• Competing physical layouts may be managed by different Physical Alternatives. 
• Different Storm Frequencies may be managed by different Rainfall Runoff 

Alternatives. 

 There are two types of Scenarios: Base Scenarios and Child Scenarios. 
• Base Scenarios have all your working data. When you start a new project, you begin 

with a default Base Scenario. As you enter data and calculate your model, you are 
working with this default Base Scenario and the alternatives it references. 

• When a Child Scenario is created, it inherits its data from its Parent. More precisely, 
its Alternatives and Calculation Options are links to the Alternatives and Calculations 
Options of its parent. 
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2. `Scenario Properties 
As stated above, Scenarios are simply a list of Alternatives and a Calculation Options definition. 
Viewing, changing, and managing the different alternatives associated with a scenario is done through 
the Properties dialog. To view the scenario properties, double-click on the scenario, or right-click on 
the scenario and choose Properties. 

A list of the alternatives associated with the scenario will be displayed in the Properties dialog. 

If you have created a new Base Scenario, all the Alternatives will be the same as in the “copied” 

Scenario. They will be copied, but they will not keep any further relationship to the original Scenario’s 
Alternatives. Changes to the original Scenario do NOT propagate to the new Base Scenario. 

If you created a Child Scenario, the scenario initially would inherit all the alternatives from the parent 
scenario. In this case, you will see the "I" next to the name of the alternative. Changes to any of the 
settings in the original scenario – a change in the Rainfall Runoff Alternative, for example -- 
automatically gets propagated to the new Child Scenario. They’re linked. 

If you manually pick an alternative without the "I," then the Child Scenario will no longer inherit any 
changes in alternatives made in the parent scenario. 
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To change any alternative for a scenario, click the pulldown beside the scenario name and select the 
alternative. 

If you have not yet created an alternative for the scenario, you can create a new alternative here as 
well, by selecting the “<New…>” item. You will be prompted to enter the name for the new alternative 
– after which the new alternative will be selected for the scenario and listed in the Alternatives 
Manager. 

3. Alternatives Manager 
The Alternative Manager lets you create, view, and edit the alternatives that make up the project 
scenarios. The dialog box consists of a pane that displays folders for each of the alternative types 
which can be expanded to display all alternatives for that type and a toolbar. 

As with Scenarios, there are two kinds of Alternatives: Base Alternatives and Child Alternatives. Base 
Alternatives hold local data for all elements in your system. Child Alternatives inherit data from Base 
Alternatives or even other Child Alternatives. The data within a Child Alternative consists of data 
inherited from its parent and the data altered specifically by you (local data). 

Remember that all data inherited from the Base Alternative is changed when the Base Alternative 
changes. Only local data specific to a Child Alternative remains unchanged. 
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4. Editing Alternatives 
To edit an alternative, expand the tree so that all the alternatives for a given type are listed. 

There are several ways to open an alternative: 
• You can double-click on the alternative. 
• You can also highlight the alternative and select the Open icon. 
• Finally, you can right-click the alternative and select Open. This will open a new 

dialog. 

Each alternative will have different properties. Any column that is shown as white is a field that can be 
edited. Columns in yellow cannot be edited from the alternative, but in some cases, may be editable 
from other places in the model, such as the FlexTables or Properties. 

The first column in any alternative editor has a check box indicating the records that have been 
changed in this alternative. If the box is checked, the record on that line has been changed, and the 
data is local, or specific, to this alternative. If the box is not checked, it means that the record on that 
line is inherited from its higher-level parent alternative. Inherited records are dynamic. If the record is 
changed in the parent, the change is reflected in the child. The records on these rows reflect the 
corresponding values in the alternative's parent. 

Changes made in the graphics, Properties, and FlexTables will automatically make changes to the 
values in the appropriate active Alternatives. 

5. Calculation Options 
The Calculation Options Manager lets you create, view, and edit the calculation options available for 
your scenarios. The dialog box consists of a pane that displays the calculation options created. 

To edit the calculation options, double-click on the one you want to edit. This will display the properties 
of the calculation options in the Properties dialog. 

The parent/child function is not available for calculation options. New calculation options can be 
created by clicking the New icon. 
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6. Computing Scenarios 
There are several places where you can compute a scenario: 

•  The Compute icon in Analysis > Calculation - this 
computes the current scenario. Use this if you are confident that you know which 
scenario this is. 

•  The Compute Centre – this lets you choose the scenario to compute and shows you 
the most important settings that it contains. Use this when you are getting familiar 
with scenarios, as a straightforward way to check their settings. 

• The Scenarios Manager – this lets you choose the scenario to compute and to 
compute multiple scenarios in a hierarchy or by selecting a batch. You will use this 
more when you are more proficient with the software and are using more scenarios. 
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Checking the Calculation Options 
By default, the Gradually Varied Flow (GVF) calculations will be used to ‘solve’ the hydraulics of a 
storm drainage network. 

(a)  On the Analysis ribbon, select Calculation > Options. 

(b) Note: The calculation options that you see here have been copied in from the DGN library.  

Note: The red tick in the icon for the Base Analysis solver icon tells you that this is the 
active calculation option. 

The most important property of a Scenario is the Calculation Option: 
• An Analysis performs calculations but does NOT change pipe sizes and levels. 
• A Design performs calculations and MAY change pipe sizes and elevations. 

(c) Double click Base Analysis in the Calculation Options dialog.  
Note that because you are editing the active Calculation Options, they will automatically be used 
by the active Scenario. 
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(d) The settings for Base Analysis are displayed in the Properties dialog.  
Your Calculation Options should be the same as the picture below.  

Notes: 
• The Active Numerical Solver is set to GVF-Rational (StormCAD) for Gradually Varied 

Flow using the Rational method. 
• The Calculation Type is set to Analysis. This will not change the pipe sizes, levels etc. – 

none of the physical data. 
• The Flow Profile Model is set to Backwater Analysis. This is the preferred option for 

computing a system, because the gradually varied flow algorithms it uses are more rigorous 
and generate solutions that more closely reflect reality. 

• The Minimum Time of Concentration is set to 10 minutes. Any catchment with no Time 
of Concentration set, or one that is less than this, will be adjusted by the calculations to use 
this value. 

• Use Minimum Time of Calculation as Minimum System Time applies when a pipe at 
the top of a branch has no flow. 

(e) Scroll further down to Calculation Options. 

(f) Locate the Use Rational Method Frequency Factors property in the Rational Method category. 
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(g) Check that the Use Rational Method Frequency Factors to False. 

(h) Locate the Allow Runoff Coefficient to Exceed 1.0 property in the Rational Method category. 

(i) Check that this is set to False. 

This setting does not allow the product of the Runoff Coefficient and the Frequency Factor to 
exceed 1.0. Checking the Active Scenario 

1. Computing the Scenario  
(a) From the Analysis ribbon, select Analysis Tools > Compute Center.   

The toolstrip at the top of the Compute Center lets you access several Managers and tools to help 
you use scenarios. It always displays the current scenario when you open the dialog, but you can 
change the scenario to compute if you need to. 

Review the other settings in the Compute Center dialog. 

Note: Settings for the Calculation Type are set to Analysis. Remember - this means that the 
physical properties of the drainage network will not be changed. A Calculation Type that is set to 
Design may well cause the physical properties -- such as invert levels and pipe diameters -- to 
change. 

(b)  Click Compute. This computes the current scenario.  
On the GVF- Rational Calculation Summary panel, click on Details 

(c) Click the Inlet Summary tab and review the data. 
You can see the Capture Efficiency of each catch basin, and the Spread / Top Width, so you can 
easily find any big issues. 
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The Catchment Summary tab also is a useful one to check at this stage, as it could reveal an 
issue with the storm data. 

(d) Close the Details dialog. 
On the GVF-Rational Calculation Summary panel, click Messages. 

Review the messages. 

(e)  Close the User Notifications dialog.  
If this is the first time that you have used the User Notifications dialog, then the Civil Message 
Center dialog will now be displayed. The content of this will be like what you’ve just seen in the 
User Notifications, but this dialog also displays MicroStation and other ORD messages.  

The buttons across the top of the dialog act as toggles, so you can click them to toggle the display 
of the errors, warnings, and information messages on and off. This also toggles on and off the 
glyphs in the graphics. 

(f) Close the Civil Message Center dialog – if it is open.  

(g) Close the GVF-Rational Calculation Summary and the Compute Center dialogs. 
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(h) User Notifications are now also shown as warning glyphs in the Default view. 

If you ever want to review the information shown in the Details dialog, you do not need to compute 
the scenario again – you can simply click Analysis > Calculation > Calculation Summary. 

You can also review the Notifications at any time – if you have already computed the scenario. 

Click Analysis > Calculations > Notifications. The User Notifications Manager displays warnings 
and error messages 

Note that if you click Messages on the Calculation Summary dialog to review the User 
Notifications, Zoom To is not available. This is because the software is still within the process of 
calculating the scenario – although the calculations have finished, the process has not – so user 
interaction is prevented. When you click Notifications on the Analysis ribbon, you are not 
within the calculation process, so Zoom To is available. The results that you see are those that 
were calculated when you last computed the scenario. 
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2. Checking Hydraulic Properties 

(a) Select a catch basin and view the Utility Properties. There are quite a lot of result fields, so if 
you want to look at the spread width in the gutter, just type in the word ‘spread’ in Property 
Search. 

(b) You can see that the inlet is operating at 43% of its efficiency. 

(c) You can also see the width of flow in the gutter is approximately 1.48’. 

(d) Select one of the catchments 

(e) Remove the ‘spread’ text from the Property Search if you typed it in. 
You can see the results for the catchment, including how much flow is coming off it. 
1) Now click on one of your catchments to review properties. Grayed out fields cannot be 

ediited from the properties window. All other properties can be changed individually or 
globally. 
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3. Checking the Default Design Constraints 
When you have computed the system previously, you have used the default settings for the spread 
width and depth. These values can be adjusted in the default design constraints. 

(a) On the Analysis ribbon, click Analysis Tools > Default Design 
Constraints. 

(b) Click on all tabs and review the default design constraints. You can make changes here to set 
your design constraints according to your project needs and standards. Most design constraint 
defaults have been set to standard values, but you may need to make some changes according to 
your project needs. 

(c) For example, if you want your structure to allow drop structure because your grade difference is 
higher than your allowed conduit slopes, click on the Node Tab. 

This will allow pipe inverts to be at different elevations. If you want to minimize depth of cover 
instead, you can uncheck the allow drop structure or check the box right below. 

(d) Close the dialog.  
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4. Reviewing the Time of Concentration in a FlexTable 
(a) Select Analysis > Analysis Views > FlexTables. 

(b) From the Drainage tab, double click Tables Predefined > Catchment Table. 

The modified Base Hydrology for the Catchments can be confirmed here. 

Note that the modification also could have been made in this dialog. Why have two dialogs – 
Alternatives and FlexTables – that both allow modifications? FlexTables always show values 
from the current scenario, so it is important that you check this before you start making changes. 
By using the Alternatives dialog, you are specifically choosing the Alternative to edit. Both 
workflows will achieve the same result. 

(c) Close the FlexTables dialog. 

(d)  Close the Notifications dialog. 

(e) Save Settings. 
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5. Best Practice for Storing the Physical Properties 
Pipe sizes, invert elevations, etc., are stored in the current Physical Alternative. Values in the current 
Physical Alternative are overwritten every time you compute, but you can create as many alternatives 
as you like. 

(a) On the Analysis > Calculation ribbon, click Alternatives. 

(b) In the Alternatives dialog, locate the Physical > Base Physical Alternative. 

Note the red tick, showing you that this is the current Alternative – the one that is used by the 
current Scenario. 

The name of the physical alternative can be changed, and additional alternatives can be created. 
Using sensible names is a good practice to adopt. Multiple alternatives can be created throughout a 
design workflow, so it makes sense to use sensible names for an audit trail. 



97 

6. Controlling Pipe Invert Elevations and Depth of Cover 
When setting up your system, pipe inverts are set to the invert elevation of the connecting nodes. 

(a) Click on a conduit in your default view and open the Utility Properties 

(b) Notice the set invert to start? and set invert to stop?, are set to true and the invert start and stop 
fields are grayed out. 
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(c) When you allow the software to compute the Design Scenario, these conduit properties are 
changed so design constraints for pipe matching can be honored. 

Design of the conduits controls their invert elevations, and the connected node will update to 
follow the conduit. 

Another setting in Default Design Constraints controls how elevations of conduits should change 
as they pass through a node. It is customary practice to have some change in elevations between the 
incoming and outgoing conduits to increase the hydraulic efficiency of the node. This is controlled on 
the Node tab. 

In this case, the Default Design Constraints are telling the software that there should be a 0.12 ft 
drop between the incoming and outgoing conduit invert elevations. 
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7. Controlling how the Default Depth of Cover is Applied 
The depth of cover to each conduit is another factor that needs to be considered during the design 
process. 

(a) Select a conduit, then click Open Profile Model. 

(b) Open View 4 and place the profile model in that view. 
Do you want to consider the depth of cover along the conduit, or just at the nodes? 

(c)  From the Analysis ribbon, select Analysis Tools > Default Design Constraints. 

The Gravity Pipe tab allows you to enter default constraints to be used for design of pipes when 
performing a calculation run in design mode. The Cover tab has a check box – Consider Cover 
Along Pipe Length? 
• If it is unchecked, the depth of cover is only checked at the nodes. 
• If it is checked, the depth of cover is checked along the pipe length. 
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Reviewing the Changes 
It is possible to select various conduits in your system and review their properties. However, it is easier to 
review and evaluate your system globally using the flex tables. 

(a) Click Analysis>Analysis view>Flex tables 

You can Select from the list of predefined tables, create a project-specific Flex Table, edit its content, and 
create a report from that. 

1. Reviewing the Available FlexTables 
(a) Click the Utilities tab. 

(b) Review the FlexTables available under Tables – Predefined.  
Note the two FlexTables – Storm Water Nodes and Storm Water Conduits. These two FlexTables 
contain data for all types of storm drainage nodes and conduits, but they do not include any 
hydraulic data, and catchment areas are not included. 

Note that FlexTables for other types of utility – Communications, Electrical, etc. -- also are 
available. 

(c) Click the Drainage tab. 

(d) Review the FlexTables that are available under Tables – Predefined.  
Note that there is no concept of a utility type on the Drainage tab because all the FlexTables 
available on this tab refer specifically, and only, to storm and sanitary drainage data. While storm 
drainage data is available in both tabs, if it is accessed from the Drainage tab, then the 
information available is richer, because it includes the hydraulic data. 

(e) Review the two icons that are used for each of the FlexTables: 

•  This icon means that data for this element type is in this design file. 

• This icon means that this design file does not contain data for this element type. 

For example, this design file contains conduits and catch basins, but it does not contain laterals or 
taps. 
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(f) If it isn’t already expanded, expand Tables – Hydraulic Model. 

• Note that there are several FlexTables listed here. These were automatically copied into this 
design file when the Utilities project was created, because they existed as Drainage 
FlexTables in the Drainage and Utilities DGN library. The same rule applies to Utilities 
FlexTables too. 

• Also, note Tables – Shared. There will not be any FlexTables listed under here – unless you 
have previously set some up on this computer. 

You have seen that there are three folders that are available at the top level. Their functionality differs, 
as follows: 
• Predefined FlexTables are shipped with the software and act as examples. You cannot create new 

FlexTables under Predefined 
• Shared FlexTables are available in every Utilities project that is opened on this computer. 
• Hydraulic Model FlexTables are only available in this Utilities project. They are stored in the design 

file. 

If you want to create FlexTables that anyone who works on the same design file can use, then 
Hydraulic Model FlexTables are an effective way to accomplish this. 

2. Copying a Predefined FlexTable 
There are two ways to create a FlexTable: 

• Copy an existing FlexTable. 
• Create a new FlexTable from scratch. 

The first method of creating a FlexTable – by copying an existing table -- is useful if the existing 
FlexTable contains similar content to what you want. The first step is to see what the existing FlexTable 
contains. 

(a) In the FlexTables dialog, on the Drainage tab, scroll down so that you can see Tables – 
Predefined. 

(b) Under Tables – Predefined, locate Conduit Table. 

(c) Right-click on Conduit Table, then click Open, or double click the table. The Conduits FlexTable is 
opened. 
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(d) Use the horizontal scrollbar to review its content. 

(e) Close FlexTable Dialog 

You will see several columns, including information on invert elevations, slope, size, etc. 
TxDOT workspace provides 3 Hydraulic model tables to use. However, these tables may not contain all 
the information your district requires for reporting your calculations. 
You can duplicate the predefine Hydraulic model table and add the information you need or remove 
information. 

(f) Right click on TxDOT Drainage Storm Sewer Table, then click Duplicate> As Hydraulic Model Flex 
Table. 

(g) Look at the FlexTables that are listed under Tables- Hydraulic Model. You will see that they now 
include Copy of TxDOT Storm Sewer Table. 
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(h) Right click on Copy of TxDOT Storm Sewer Table. Then click Edit. 

(i) While there are a few special FlexTables that let you combine nodes and conduits in a single 
FlexTable – the Network Elements FlexTable is one example – FlexTables normally only show data 
for a single element type. 

Note the Table Type shown at the top of the dialog. This is a read-only field, which says Conduit in 
this case. This dialog lets you change the content of the FlexTable. The list on the left-hand side 
shows the available columns, and the list on the right-hand side shows the selected columns. 

You can add or remove columns from the table and select the placing of new added columns using the 
up or down arrows. In this case, a column for the size was added. 
You can rename your table. 

(j) You Right-click on Copy of TxDOT Storm Sewer Table, then click Rename. 

(k) Type TxDOT (your district) Storm Sewer Table. 
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3. Formatting the Conduit FlexTable 
To format the flex tables 

(a) Right Click on the column you wish to format. 

(b) Select Units and Formatting. 

(c) Change your setting in the dialog window. 

Note that all columns with the elevation formatter will share the same format. If you change the units 
or display precision, it will change it for all columns that report an elevation. 

(d) Right-click on the title text of the Label column. 

(e) Click on Sort Dendritic (Upstream > Downstream). 

This sorts the order of the conduits so they are listed in dendritic order.  All branches of your 
system that come to a single node from upstream to downstream will be together. 

You can also edit the column label. Open the TxDOT Drainage area Table. You will notice that the 
intensity and Run-Off columns do not have a return year. To update the values, simply click on the Edit 
Column label of the menu on the right and update your return year. 
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4. Producing a Reports from FlexTable 

(a) On the Home ribbon, click Export Utilities > Export Excel. 

By default, Conduit is the selected Element Type in Specify Properties to Export. The column to the 
right of that, labeled Table/Properties, says <All Properties>, and the Is Filtered? column says 
False. 

These settings show that, if you click OK now, this tool will export all the properties for every 
element type that exists in the model. This can amount to a lot of properties, and – depending on 
the purpose of the report – are probably many more than you need. 

(b) Use the vertical scroll bar on the right-hand side of the dialog to review the available properties for 
a conduit. 

(c) Note the controls above the vertical scroll bar: 
• Table/Properties 
• Table Path 
• Filter 

These controls can be used to control the content included for each element type. 

(d) Ensure that Conduit is the selected row in Specify Properties to Export and that the check box for 
it is checked on. 
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(e) Click in the <All Properties> field on the right-hand side of the dialog. 
(f) The drop-down list includes all FlexTables which are valid for the Conduit element type. 

Note that you can select FlexTables from any location – Predefined, Shared, and Hydraulic Model. 

(g) Click on TxDOT Storm Sewer Table. 
The dialog tells you that this FlexTable is stored under Tables – Hydraulic Model, so you know that 
it is stored in this design file. 

Note that the Filter control says <None> because the FlexTable you have selected does not have a 
filter. 

(h) Use the vertical scroll bar to review the list of properties that now are included for conduits. It’s a 
lot less. 

Your dialog should be the same as the picture above. 

Use the same procedure to select your catch Basin (TxDOT Inlet Table) and Catchment (TxDOT 
Drainage Area Table). 

(i) Click OK to create the spreadsheet. 
(j) In the Export to Excel dialog, type in file name Composite Report. 
(k) Click the Save button. 
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(l) If you have Excel (or a viewer for Excel files) on your computer, you can locate the file using 
Windows Explorer, and open it. 

The spreadsheet contains a sheet for each selected element type. If you review row 1 on each 
sheet, you will see the columns that you selected in the FlexTables. Note that the Scenario and 
Timestep columns are added automatically. 

5. Techniques for Controlling the Elements to Include 
The Export to Excel dialog gives you several ways to control which elements are included in the report. 
This section will briefly discuss each of these methods. 

• Using a Filter 
• Using a Selection Set 
• Excluding Topologically Inactive Elements 

(a) Using a Filter 
FlexTables can have a filter applied to any included column, so you could, for example, only include 
the elements that use a particular feature definition or have a certain size range. You can either create 
a filter directly in the FlexTable, or you can create a Query first, then use it to filter the FlexTable. 

(b) Using a Selection Set 
Selection sets may be a more flexible technique to use than filters, for several reasons: 

• A comprehensive set of predefined Queries is included in the software. 
• It is easy to build your own query, using any available fields and operators (And, Or <, 

>, etc.). 
• Queries can be saved and reused as needed. 

The basic workflow is to: 
1) Click Queries on the Utilities View ribbon. 
2) Identify the queries to use, or create your own. 
3) Click Selection Sets on the Utilities View ribbon. 
4) Select the Queries to use in the Selection Set. 
5) Select the Selection Set in the Export to Excel tool. 

An example of where this functionality could be useful is if you have more than one network in your 
design file, but you want to create a separate report for each network. Because each element in a 
drainage network has a property for the Subnetwork Outfall, you could use this to create queries for 
each one. 
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(c) Excluding Topologically Inactive Elements 
Each drainage element has an “Is Active?” property, which controls whether it is active or not in the 
Physical alternative of a scenario. This offers another method that is useful when there are multiple 
networks in one design file. 

The basic workflow is to: 
1) Create a Physical alternative for each network. 
2) Create a Scenario for each network. 
3) Select the appropriate Physical alternative for each Scenario. 
4) Make one of the Scenarios current. This will make all elements not in it inactive. 
5) Check the Exclude topologically inactive elements in the Export to Excel tool.  

Conversely you can create active topology alternatives to exclude elements from your flex table by 
turning off the “is Active” toggle 

6. Assigning a Station and Offset Reference to Nodes 
The first step to include information on the stations and offsets in a report is to assign the relevant 
linear feature, such as an alignment, to the nodes. The station and offset values are calculated by 
raising a normal from the node location point to the linear feature. 

If during your design process, you do not use a baseline as your reference alignment (the baseline 
reference is unchecked), it is possible to assign station offset to your element. 

(a)  Open the Explorer window. 

(b)  Open the Properties window. 

(c) In the Explorer window, expand the Drainage and Utilities Model. 
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(d) Continue to expand until you see all the Nodes (Intersection_Drainage.dgn > Nodes). 

(e) Highlight all the nodes, that are not linked to an alignment baseline or centerline to add them to a 
Selection Set. To do this, select the first node, press the Shift key, then select the last node. You 
can also use the Control key to add individual nodes to the selection. There are other tools, such 
as Queries and FlexTables, that also can be used to create a Selection Set. 

(f) Confirm that the Selection Set contains all the nodes you need by looking along the bottom of the 
product window – where toolbars like AccuSnap often are docked. The number of elements 
selected is shown here. 

(g) In the Properties window, locate the Baseline Reference property in the Utility section. It is 
currently set to None.  

(h) Click in the property field, and click on the browse icon (three dots) on the right side of the 
property field. 

(i) You are prompted to Select Reference. 

(j) Select the centerline or baseline of your choosing. To avoid picking other graphics, such as the 
catchment areas, it is easiest to window to the top of View 1. 
This will set the Station/Offset Reference for all the selected nodes. 
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(k) Confirm that the Utility Properties now show SH46 in the Station/Offset Reference property. 

(l)Click the Select None  icon to 
clear the Selection Set. This can be done by clicking in an 
area of View 1 that does not contain any graphics. 

(m) Select a node and open the Utility Properties. 

(n) Confirm that the Baseline Station and Baseline Offset properties have values. 
These values will update automatically if a node is moved. 

Note that these values are shown in the Utility Properties dialog, but not the Properties dialog. They 
are listed here so that they can be included in FlexTables. If the Baseline REF is set but is not showing 
up in the FlexTables, you can run a “Synchronize Drawing” command. This should trigger those 
missing values to be populated appropriately. (Drainage & Utilities > Tools > Project Tools Group > 
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7. Embedding the Spreadsheet in the Design File 
Your hydraulic data will need to be reported in hydraulic data sheets in your plans. You can achieve 
this by embedding the content of a spreadsheet in the design file. You have just learned how you can 
create spreadsheets that include the content you need, in the layout that you like. Runoff 
computations, inlet computations, and storm sewer computations can be extracted from the 
FlexTables. 

(a) On the analysis tab click on FlexTables. 

(b) Double click on the desired table to open. 

(c) Click the Export To File icon to export the file to .csv format. 

(d) Set the Save as type to Comma Delimited File (.csv). 

(e) Name the file Runoff Computations.csv.  (This is an example of one of your choices.) 

(f) Click Save. 

(g) Close the Flex Tables dialog. 

(h) On the Drawing Production ribbon, click Tables > Place Tables. 

(i) Change the Text Style so the table is a reasonable size 
• In Imperial, Arial .0083 Ctr Ctr may be an excellent choice 
• In metric, Arial 2.5mm Ctr Ctr may be a desirable choice 

(j) Click the From file icon. 

(k) Select the Browse icon. 

(l) Change the file type to Comma-separated (*.csv) 

(m) Browse to and select the My Catch Basin Table.csv file that you created in the last section. 7. 
Click Open.  After a few seconds, the table will be attached to your cursor. 

(n) Place Table dialog opens. Just select OK. 

(o) Left click in View 1 to place the table into the design file.  

(p) Using the Element Selection tool, select the table. 

Note that the table changes its appearance to rows and columns like a spreadsheet. 
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Because the Retain Association option is checked on, the table is graphically linked to the .csv file. 

When tables are created from a file using this tool, they become very much like a spreadsheet. 

Also, note that the ribbon menu changes and gives you access to common spreadsheet tools that can 
be used with the table. 

Left click anywhere in View 1 to de-select the table. 

Note: TxDOT will continue to use Axiom as the preferred method to embed tables in your plan set. Any resource 
files needed to set up your drainage table preferences will be posted to the external ORD site 
https://www.txdot.gov/business/resources/design-tools-training/OpenRoads-designer.html 
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Plans Production sheet cutting 

1. Create Drainage Container File 
(a) In ORD navigate to File > New > Select No Wizard > OK. 

Folder: Select Change… > navigate to the Project Folder > 4 - Design > Plan Set > 5. Drainage > 
Select OK. 

Document: 
Name: Drainage container file name. Example: SH46_Container_Drainage 
Description: Drainage proposed – SH46 - Container 
Source Document: TxDOT_DesignSeed2d.dgn - TxDOT_DesignSeed2d.dgn 
(Select Seed > Select TxDOT_DesignSeed2d.dgn > Select Open > Select Yes on the Ready Only 
Dialog) 

(b) Select OK to create the New file in ORD. 
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(c) Attach the reference files with no nesting such as terrain files, geometry, corridor, drainage 
design. 

(d) Activate the Drainage and Utility Project 
Within the file > select a node > hover and select Utility Properties >. Click Yes to activate the Drainage 
and Utility Project. 

This will enable you to view and label the drainage and utilities properties of the drainage structures 
and conduits. 

2. Set up the Profile View 
We will now Create a projected Profile run for drainage profiles and P&Ps 
a) Select layout tab. 
b) Under profile runs, select hydraulic runs to outfall. 

c) Follow the context menu prompts to create your profile run. 
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d) Once created, use the “Project Run” tool to project the profile run to the selected baseline. 

(e) Follow the plan production workflow for profile and P&P sheet creation with the Utility Profile 
Run shown. 

A profile view of the utility profile needs to be set up in the container file to be able to create Profile sheet(s) 
of the drainage system. 

(f) In the plan view, using the Element Selection tool select the utility profile run in the Default 
view. 

(g) Hover, and wait for the head-up menu to appear. From there, select the Open Profile view, open 
another view, and click within for the profile run to display.  Fit view. 
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(h) Arrange View 1, Default and the Profile View (BL OR CENTERLINE PROFILE WITH PROJECTED 
DRAINAGE PROFILE) 

(i) Save Settings. 

We are now ready to create the different boundary types to cut our sheets. 

3. To create Plan sheets for Drainage area maps or layouts 
1. Create Plan Named Boundaries for Plan Sheets 

a) Navigate to the ribbon > Named Boundaries > Select Named Boundary 

b) In the Place Named Boundary dialog box, select Civil Plan mode. 
c) Navigate to Drawing Seed > select “Plan 1” and set the Detail Scale: 1” = 100. Once this seed 

is selected, other fields in the Place Named Boundary dialog box will be auto populated with 
default values configured in the seed file. 

d) Follow the prompt in the bottom left corner of the screen. 
e) Place Named Boundary Civil Plan > Identify Path Element > In the 2D view, 
f) select your project’s Geometry baseline. 
g) Populate the Place Named Boundary Civil Plan dialog box as needed to show all drainage on 

plan sheets. 
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h) Move the cursor anywhere in the Plan view and follow the prompt on the bottom left corner of 
the screen > Left-Click through the prompts to complete. 

i) The sheet boundaries are placed. 

The Create Drawing dialog box will open after the sheet boundaries are placed. 

2. Create Plan Sheets 
The new automated sheet creation process produces a pair of design file models for each “cut” sheet 
in the Drawing Model and Sheet Model. 
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Populate the Create Drawing dialog box with the following: 

(a) At the top select Mode -Plan 

There is a togle box to select whether you want to create a sheet per DGN. If your project 
is large and you have many sheets it is recommended to turn this toggle on and select 
the location and name of your DGN sheet files. 

(b) Drawing Model Name: 

(i) Change the Model Name field to SH46-DRG-1. 

(ii) Verify the Drawing Model Annotation Scale is 1”=100’. 

(c) Sheet Model: 

(i) Change the Model Name field to SH46-DRG-1. 

(ii) Verify the Sheet Model Annotation Scale is Full Size 1:1 and the Detail Scale is 
1”=100’. 

(iii) Leave the auto-populated values in the rest of the fields.Enable Add to Sheet Index -> 
select a folder from sheet index -> 05_Drainage (if you want to add to the Sheet 
Index) 
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(d) > Select OK 

3. View the plan set  
Open a plan drawing model and a plan sheet model. 

4. Creating the Profile Sheets 

1. Creating the Profile Named Boundaries for Profile Sheets 
If the elevation difference in your profile is too large you will not be able to create plan and 
profile sheets. We will now show you how to create profile sheets. 

(a) Navigate to ribbon > Named Boundaries > select Named 
Boundary. 

(b) In the Place Named Boundary dialog box > select the Civil Profile mode. 

(c) Navigate to Drawing Seed > select Profile 1. 

(d) Verify the Detail Scale is set to 1”=100. 

(e) Once this seed is selected, other fields in the Place Named Boundary dialog box 
will auto-populate with default values configured in the seed file. 

(f) Follow the prompt in the bottom left corner of the screen. 

(g) Place Named Boundary Civil Profile > Identify Profile View > Left click in the profile 
view. 
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(h) Populate the Place Named Boundary Civil Plan dialog box as shown below. 

(i) Move the cursor anywhere in the profile view and follow the prompt on the bottom 
left corner of the screen > Left Click through the prompts to place the profile 
boundaries. 

The Create Drawing dialog box will open after the profile boundaries are placed. 
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2. Creating the Profile sheets. 

(a) Populate the Create Drawing dialog with the following. 

(b) Drawing Model: 

(c) Change the Name field to DRG_PRF-1. 

(d) Verify the Drawing Model Annotation Scale is 1”=100’. 

(e) Sheet Model: 

(f) Change the Model Name field to DRG_PRF-1. 

(g) Verify the Sheet Model Annotation Scale is Full Size 1:1 and the Detail Scale is 
1”=100’. 

(h) Leave the auto-populated values in the rest of the fields. 

(i) Enable Add to Sheet Index -> select a folder from sheet index -> 05_Drainage (if 
you want to add to the Sheet Index). 

(j) > Select OK. 
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(k) Review the plan set 
Open a profile drawing model and a profile sheet model. 

5.  Create a Plan Profile sheet 
Follow the steps for creating the plan named Boundary but use the Plan Profile seed. 

Do the same for the profile boundary but change the Method to From Plan Group. 

Follow the workflow for creating the sheets. 
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6.  Create Cross Culvert Layout sheets, 
A culvert Layout sheet is a P&P sheet cut at the location of your proposed cross culvert. 

To set up your file, create an alignment at the CL of your culvert and extend just pass your Right of 
Way. Give your CL a sensible name, you can classify your culverts by number as they appear up station 
of your CL alignment. 

(l) Select the alignment and open the profile Model: 

(m) In the profile view, select the Create 3D Cut Tool from the menu bar. 

(n) Select Full Profile as the placement method. 

(o) Your profile view should adjust to show the proposed 3D elements. 

(p) Follow the workflow for creating Plan and profile sheets. 
NOTE: Make sure to select the appropriate scale for your drawing. 
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7. Cross section of the drainage crossings on roadways – Lateral sheets. 
Use an event point list. This will allow you to create cross sections at each crossing when cutting cross 
sections. 

From the Geometry ribbon, select Common Tools group >. Select Event Point List and follow the 
prompts: Locate Alignment > Select your baseline geometry. The Event Point List box opens > Create a 
new list > Click the Add List icon, in the New Event Point List > Enter the Name: Drainage > Select OK. 

Select the Add by Station and Offset icon, follow the prompts, and add the station and offset along the 
alignment where there is a drainage crossing. 

1. Create Cross Section Named Boundaries 
Navigate to ribbon > Named Boundaries group > Select Named Boundary 

In the Place Named Boundary dialog box, select the Civil Cross Section mode. 

(a) Navigate to Drawing Seed > Select “XS Sheet.” After this seed is selected, other 
fields in the Place 

(b) Named Boundary dialog box will be auto populated with default values configured 
in the seed file. 

(c) Follow the prompt in the bottom left corner of the screen. 

(d) Place Named Boundary Civil Cross Section > Identify Path Element – In the 2D 
view, select the baseline. 
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(e) Populate the Place Named Boundary Civil Cross Section dialog box as shown 
below. 

(f) Move the cursor anywhere in the Plan view and follow the prompt on the bottom 
left corner of the screen > Left-click through the prompts to complete. 

The Create Drawing dialog box will open after the sheet boundaries are placed. 
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2. Create Cross Section Sheets 
The fields are auto populated based on the Drawing Seed file selected in the earlier section XS Sheet. 

(a) Drawing Model 

(b) Change the Model Name field to DRG_XSC-1. 

(c) Verify that the Drawing Model Annotation Scale is set to 1” = 20’. Note: This is the 
prefered scale, but it may vary according to the size of your section 

(d) Sheet Model 

(e) Verify the Sheet Model Annotation Scale is Full Size 1:1 and the Detail Scale is 1” = 
20’. 

(f) Leave the auto populated values in the rest of the fields. 

(g) Enable Add to Sheet Index > Select a folder from sheet index > 05_Drainage (if you 
want to add to the Sheet Index) 

(h) > Select OK. 
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3. Review the cross section set 
Open a cross section drawing model and a cross section sheet model. 
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Plans Production Annotating the Drainage Plan set 
With this current version of TxDOT ORD DU workspace, the annotation is not yet automated, but we 
have created a tool in the Drainage and Utilities ribbon to help with it. Improvements will be coming 
soon. 

Workflow: Drainage and Utilities; Ribbon Tab: Drawing Production DU; Ribbon Group: DU Plan 
Production 

Annotation should be in the drawing model of your plan production file. Open your plan view to the 
drawing model. Open a Plan Drawing Model. 

Use the Element Selection tool to highlight the drainage item you want to annotate. 
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Click on the structure: Inlet, in the properties box all the information needed to label this structure is 
there. Also open the Utility Properties if more information is needed (Station and Offset). From here 
you will copy and paste into the Text Editor the information needed for the drainage structure/Conduit. 

Select the Place DU Note command. 
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This will start the command to place a label/note in your drawing model. The “Place Note” toolbox 
should appear along with the Text Editor box. 

The command will pick the correct element template (attributes), text style, and dimension style. 

Ready to fill in the drainage information for the Place Note command. 

In the properties box, select what you want to copy and paste, highlight, right-click, copy, move to Text 
Editor, right click, paste. Continue until all text needed has been added to the Text Editor window. Next 
click in the plan view on the structure once more, click again to where you want the text to be placed. 
Repeat as needed for all drainage items. 
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Do the same with the conduits, using Element Selection tool, select the conduit, click on the “Place DU 
Note” command, copy, and paste from the properties items as needed, select the conduit once more, 
place the text. 

To label/annotate the catchment area (drainage area) you will change the “Place DU Note” tool from 
‘Place Note’ to ‘Place Callout.’  As before, using the Element Selection tool, click on the drainage area 
for the properties, copy and paste, and place the callout. 


	ORD - DU Introduction and Workflows
	Table of Contents
	Introduction
	Drainage and Utility Tools
	1. Home tab
	2. Layout tab
	3. Analysis tab
	4. Components tab
	5. Utilities View tab
	6. Tools Tab
	7. Report Tab
	8. Drawing Production Tab

	Project Setup
	1. Folder structure and reference files location.
	2. Create a new Drainage Design
	3. Set up your geographic coordinate system
	4. Attach reference files

	Drainage system Layout
	1. Place an Outfall
	2. Place Drainage Node Without Automatic Catchment
	3. Place Drainage Node With Automatic Catchment
	4. Assigning a predefined area to a structure – picking your catchment.
	5. Setting the Minimum Time of Concentration
	6. Setting the Time of Concentration for the Catchment Areas
	7. Placing Gutters
	1) Methods of Placing a Gutter
	2) the Gutter shape
	3) Placing a Gutter – Trace Slope Method
	4) Between Nodes Method

	8. Place Conduits and inserting nodes
	1) `Place Conduits
	2) Insert nodes

	9. Drainage system layout - special workflows
	1) Extend Existing Pipe Using a Transition Node
	2) Place POD inlets and lateral connections

	10. Create Profile

	Compute the system
	1. Setting up the storm event
	2. Run the Analysis Scenario – Compute your System
	3. Invert Values during Layout and Design
	4. Let the Software Design the System

	Placing ditch and culvert Network
	1. Place the Headwall and Endwall
	2. Place the Pipe
	3. Place the Outfall
	4. Place the Ditch
	5. Break the Ditch
	6. Place and Design a Cross Culvert
	Make the Pipe a Culvert


	Controlling Object Design
	1. Pipe Sizes available for Design
	2. Conduit Properties

	Understanding Scenarios
	1. Scenario Manager
	2. `Scenario Properties
	3. Alternatives Manager
	4. Editing Alternatives
	5. Calculation Options
	6. Computing Scenarios

	Checking the Calculation Options
	1. Computing the Scenario
	2. Checking Hydraulic Properties
	3. Checking the Default Design Constraints
	4. Reviewing the Time of Concentration in a FlexTable
	5. Best Practice for Storing the Physical Properties
	6. Controlling Pipe Invert Elevations and Depth of Cover
	7. Controlling how the Default Depth of Cover is Applied

	Reviewing the Changes
	1. Reviewing the Available FlexTables
	2. Copying a Predefined FlexTable
	3. Formatting the Conduit FlexTable
	4. Producing a Reports from FlexTable
	5. Techniques for Controlling the Elements to Include
	6. Assigning a Station and Offset Reference to Nodes
	7. Embedding the Spreadsheet in the Design File

	Plan Production Sheet Cutting
	1. Create Drainage Container File
	2. Set up the Profile View
	3. To create Plan sheets for Drainage area maps or layouts
	4. Creating the Profile Sheets
	If the elevation difference in your profile is too large you will not be able to create plan and profile sheets. We will now show you how to create profile sheets.

	5. Create a Plan Profile sheet
	6. Create Cross Culvert Layout sheets,
	7. Cross section of the drainage crossings on roadways – Lateral sheets.

	Plans Production Annotating the Drainage Plan set



